Back to overview
Resolved

Increased Latency and timeouts

Apr 20, 2026 at 1:28pm UTC
Affected services
app.us.lumiasecurity.com

Resolved
Apr 20, 2026 at 3:06pm UTC

The service has been stabilized and returned to normal operation. During the disruption, some requests were not processed and users may have experienced increased latency. We have mitigated the issue and are continuing to investigate and implement improvements to prevent similar incidents in the future.

Updated
Apr 20, 2026 at 2:13pm UTC

We have identified the root cause of the system instability and are actively working on a fix.

Created
Apr 20, 2026 at 1:28pm UTC

We are investigating reports of increased latency and timeouts of the proxy service for certain customers.